Cisco IPv6 6to4 tunnel

en
conf t
host R1
int s1/2
ip add 16.16.16.1 255.255.255.0
no shut
int loop0
ip add 129.53.1.1 255.255.255.0
router rip
ver 2
network 0.0.0.0
no auto
!
int loop1
ipv6 address 2002:8135:101:1::1/64
!
interface tunnel 126
tunnel source loop0
tunnel mode ipv6ip 6to4
ipv6 address 2002:8135:101::1/64
!
ipv6 route 2002::/16 tunnel 126

en
conf t
host R2
int s1/2
ip add 26.26.26.2 255.255.255.0
no shut
int loop0
ip add 129.53.2.2 255.255.255.0
router rip
ver 2
network 0.0.0.0
no auto
!
int loop2
ipv6 address 2002:8135:202:2::2/64
!
interface tunnel 126
tunnel source loop0
tunnel mode ipv6ip 6to4
ipv6 address 2002:8135:202::1/64
!
ipv6 route 2002::/16 tunnel 126

en
conf t
host R6
int s2/2
ip add 26.26.26.6 255.255.255.0
no shut
int s2/1
ip add 16.16.16.6 255.255.255.0
no shut
int loop0
ip add 129.53.6.6 255.255.255.0
router rip
ver 2
network 0.0.0.0
no auto
!
int loop6
ipv6 address 2002:8135:606:6::6/64
!
interface tunnel 126
tunnel source loop0
tunnel mode ipv6ip 6to4
ipv6 address 2002:8135:606::1/64
!
ipv6 route 2002::/16 tunnel 126

foreach ipv6 {
2002:8135:101:1::1
2002:8135:202:2::2
2002:8135:606:6::6
} { ping $ipv6 }

R2(tcl)#foreach ipv6 {
+>(tcl)#2002:8135:101:1::1
+>(tcl)#2002:8135:202:2::2
+>(tcl)#2002:8135:606:6::6
+>(tcl)#} { ping $ipv6 }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:8135:101:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:8135:202:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/3/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:8135:606:6::6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms
R2(tcl)#

Screenshot 2014-03-28 06.59.10

Advertisements

MPLS LDP bindings detail – MPLS IP bindings detail

!
R4, R5, R6:
access-list 10 permit 150.1.0.0 0.0.255.255
access-list 10 permit 150.9.0.0 0.0.255.255
!
no mpls ldp advertise-labels
mpls ldp advertise-labels for 10

MPLS LDP bindings detail:

Rack9R4#sh mpls ldp bindings
lib entry: 54.9.1.0/24, rev 21
local binding: label: 16
lib entry: 150.9.4.4/32, rev 31
local binding: label: imp-null
remote binding: lsr: 150.9.5.5:0, label: 17
remote binding: lsr: 150.9.6.6:0, label: 16
lib entry: 150.9.5.5/32, rev 32
local binding: label: 17
remote binding: lsr: 150.9.5.5:0, label: imp-null
remote binding: lsr: 150.9.6.6:0, label: 17
lib entry: 150.9.6.6/32, rev 33
local binding: label: 18
remote binding: lsr: 150.9.5.5:0, label: 18
remote binding: lsr: 150.9.6.6:0, label: imp-null
lib entry: 155.9.0.0/24, rev 25
local binding: label: imp-null
lib entry: 155.9.5.0/24, rev 26
local binding: label: 19
lib entry: 155.9.45.0/24, rev 27
local binding: label: imp-null
lib entry: 155.9.58.0/24, rev 28
local binding: label: 20
lib entry: 155.9.146.0/24, rev 29
local binding: label: imp-null
lib entry: 204.12.9.0/24, rev 30
local binding: label: imp-null
Rack9R4#

Rack9R4#sh mpls ldp bindings detail
Advertisement spec:
Prefix acl = 10

lib entry: 54.9.1.0/24, rev 21, chkpt: none
local binding: label: 16 (owner LDP)
route information: state: none, table: default,
next-hop: 155.9.146.6, remote label:
lib entry: 150.9.4.4/32, rev 31, chkpt: none
local binding: label: imp-null (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
remote binding: lsr: 150.9.5.5:0, label: 17
remote binding: lsr: 150.9.6.6:0, label: 16
route information: state: none, table: default,
next-hop: 0.0.0.0, remote label:
Advert acl(s): Prefix acl 10
lib entry: 150.9.5.5/32, rev 32, chkpt: none
local binding: label: 17 (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
remote binding: lsr: 150.9.5.5:0, label: imp-null
remote binding: lsr: 150.9.6.6:0, label: 17
route information: state: none, table: default,
next-hop: 155.9.0.5, remote label: imp-null
route information: state: none, table: default,
next-hop: 155.9.45.5, remote label: imp-null
Advert acl(s): Prefix acl 10
lib entry: 150.9.6.6/32, rev 33, chkpt: none
local binding: label: 18 (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
remote binding: lsr: 150.9.5.5:0, label: 18
remote binding: lsr: 150.9.6.6:0, label: imp-null
route information: state: none, table: default,
next-hop: 155.9.146.6, remote label: imp-null
Advert acl(s): Prefix acl 10
lib entry: 155.9.0.0/24, rev 25, chkpt: none
local binding: label: imp-null (owner LDP)
route information: state: none, table: default,
next-hop: 0.0.0.0, remote label:
lib entry: 155.9.5.0/24, rev 26, chkpt: none
local binding: label: 19 (owner LDP)
route information: state: none, table: default,
next-hop: 155.9.0.5, remote label:
route information: state: none, table: default,
next-hop: 155.9.45.5, remote label:
lib entry: 155.9.45.0/24, rev 27, chkpt: none
local binding: label: imp-null (owner LDP)
route information: state: none, table: default,
next-hop: 0.0.0.0, remote label:
lib entry: 155.9.58.0/24, rev 28, chkpt: none
local binding: label: 20 (owner LDP)
route information: state: none, table: default,
next-hop: 155.9.0.5, remote label:
route information: state: none, table: default,
next-hop: 155.9.45.5, remote label:
lib entry: 155.9.146.0/24, rev 29, chkpt: none
local binding: label: imp-null (owner LDP)
route information: state: none, table: default,
next-hop: 0.0.0.0, remote label:
lib entry: 204.12.9.0/24, rev 30, chkpt: none
local binding: label: imp-null (owner LDP)
route information: state: none, table: default,
next-hop: 0.0.0.0, remote label:
Rack9R4#

MPLS IP bindings detail

Rack9R4#sh mpls ip binding
54.9.1.0/24
in label: 16
150.9.4.4/32
in label: imp-null
out label: 17 lsr: 150.9.5.5:0
out label: 16 lsr: 150.9.6.6:0
150.9.5.5/32
in label: 17
out label: imp-null lsr: 150.9.5.5:0 inuse
out label: 17 lsr: 150.9.6.6:0
150.9.6.6/32
in label: 18
out label: 18 lsr: 150.9.5.5:0
out label: imp-null lsr: 150.9.6.6:0 inuse
155.9.0.0/24
in label: imp-null
155.9.5.0/24
in label: 19
155.9.45.0/24
in label: imp-null
155.9.58.0/24
in label: 20
155.9.146.0/24
in label: imp-null
204.12.9.0/24
in label: imp-null
Rack9R4#

Rack9R4#sh mpls ip binding detail
Advertisement spec:
Prefix acl = 10

54.9.1.0/24, rev 21, chkpt: none
in label: 16 (owner LDP)
150.9.4.4/32, rev 31, chkpt: none
in label: imp-null (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
out label: 17 lsr: 150.9.5.5:0
out label: 16 lsr: 150.9.6.6:0
Advert acl(s): Prefix acl 10
150.9.5.5/32, rev 32, chkpt: none
in label: 17 (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
out label: imp-null lsr: 150.9.5.5:0 inuse
out label: 17 lsr: 150.9.6.6:0
Advert acl(s): Prefix acl 10
150.9.6.6/32, rev 33, chkpt: none
in label: 18 (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
out label: 18 lsr: 150.9.5.5:0
out label: imp-null lsr: 150.9.6.6:0 inuse
Advert acl(s): Prefix acl 10
155.9.0.0/24, rev 25, chkpt: none
in label: imp-null (owner LDP)
155.9.5.0/24, rev 26, chkpt: none
in label: 19 (owner LDP)
155.9.45.0/24, rev 27, chkpt: none
in label: imp-null (owner LDP)
155.9.58.0/24, rev 28, chkpt: none
in label: 20 (owner LDP)
155.9.146.0/24, rev 29, chkpt: none
in label: imp-null (owner LDP)
204.12.9.0/24, rev 30, chkpt: none
in label: imp-null (owner LDP)
Rack9R4#

Cisco redistribution – show commands

Rack6R4(config-router)#do sh run | s router
router eigrp 1
redistribute rip metric 1 1 1 1 1
network 155.6.0.0 0.0.0.255
no auto-summary
router ospf 1
log-adjacency-changes
network 155.6.45.4 0.0.0.0 area 0
network 155.6.146.4 0.0.0.0 area 0
router rip
version 2
redistribute eigrp 1 metric 10
network 204.12.6.0
distance 109

To see the EIGRP routes redistributed into RIP:

Rack6R4(config-router)#do sh ip rip data | i redistributed
150.6.8.0/24 redistributed
150.6.10.0/24 redistributed
155.6.0.0/24 redistributed
155.6.5.0/24 redistributed
155.6.8.0/24 redistributed
155.6.10.0/24 redistributed
155.6.58.0/24 redistributed
155.6.108.0/24 redistributed

Rack6R4(config-router)#do sh ip route ei
155.6.0.0/24 is subnetted, 13 subnets
D 155.6.8.0 [90/2172672] via 155.6.0.5, 00:24:08, Serial0/0/0.1
D 155.6.10.0 [90/2175232] via 155.6.0.5, 00:24:08, Serial0/0/0.1
D 155.6.5.0 [90/2172416] via 155.6.0.5, 00:24:08, Serial0/0/0.1
D 155.6.58.0 [90/2172416] via 155.6.0.5, 00:24:08, Serial0/0/0.1
D 155.6.108.0 [90/2174976] via 155.6.0.5, 00:24:08, Serial0/0/0.1
150.6.0.0/16 is variably subnetted, 6 subnets, 2 masks
D 150.6.8.0/24 [90/2300416] via 155.6.0.5, 00:24:08, Serial0/0/0.1
D 150.6.10.0/24 [90/2302976] via 155.6.0.5, 00:24:08, Serial0/0/0.1

To see the RIP routes redistributed into EIGRP:
Rack6R4(config-router)#do sh ip route rip
31.0.0.0/16 is subnetted, 4 subnets
R 31.3.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 31.2.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 31.1.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 31.0.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
30.0.0.0/16 is subnetted, 4 subnets
R 30.2.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 30.3.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 30.0.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 30.1.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
Rack6R4(config-router)#do sh ip eigrp topo | i Redist
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
8 rip routes Plus the local connected:
P 204.12.6.0/24, 1 successors, FD is 2560000256
via Redistributed (2560000256/0)

To see the any route redistributed into OSPF:

router ospf 1
log-adjacency-changes
network 155.6.37.3 0.0.0.0 area 0
redistribute eigrp 1 subnets

Rack6R3(config-router)#do sh ip ospf data | b Type-5
Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
30.0.0.0 150.6.3.3 1182 0x80000001 0x00BD22 0
30.1.0.0 150.6.3.3 1182 0x80000001 0x00B12D 0
30.2.0.0 150.6.3.3 1182 0x80000001 0x00A538 0
30.3.0.0 150.6.3.3 1182 0x80000001 0x009943 0
31.0.0.0 150.6.3.3 1182 0x80000001 0x00B02E 0
31.1.0.0 150.6.3.3 1182 0x80000001 0x00A439 0
31.2.0.0 150.6.3.3 1182 0x80000001 0x009844 0
31.3.0.0 150.6.3.3 1182 0x80000001 0x008C4F 0
150.6.8.0 150.6.3.3 86 0x80000002 0x00FC5B 0
150.6.10.0 150.6.3.3 86 0x80000002 0x00E66F 0
155.6.0.0 150.6.3.3 86 0x80000002 0x001447 0
155.6.5.0 150.6.3.3 86 0x80000002 0x00DC79 0
155.6.8.0 150.6.3.3 86 0x80000002 0x00BB97 0
155.6.10.0 150.6.3.3 86 0x80000002 0x00A5AB 0
155.6.58.0 150.6.3.3 87 0x80000002 0x00938D 0
155.6.108.0 150.6.3.3 87 0x80000002 0x006B83 0
204.12.6.0 150.6.3.3 87 0x80000002 0x000A14 0

Rack6R3(config-router)#do sh ip route eig
155.6.0.0/24 is subnetted, 15 subnets
D 155.6.8.0 [90/20514816] via 155.6.0.5, 00:35:31, Serial1/0.1
D 155.6.10.0 [90/20517376] via 155.6.0.5, 00:35:31, Serial1/0.1
D 155.6.5.0 [90/20514560] via 155.6.0.5, 00:35:31, Serial1/0.1
D 155.6.58.0 [90/20514560] via 155.6.0.5, 00:35:31, Serial1/0.1
D 155.6.108.0 [90/20517120] via 155.6.0.5, 00:35:31, Serial1/0.1
D EX 204.12.6.0/24 [170/2561024256] via 155.6.0.5, 00:35:31, Serial1/0.1
31.0.0.0/16 is subnetted, 4 subnets
D EX 31.3.0.0 [170/2561024256] via 155.6.0.5, 00:20:01, Serial1/0.1
D EX 31.2.0.0 [170/2561024256] via 155.6.0.5, 00:20:01, Serial1/0.1
D EX 31.1.0.0 [170/2561024256] via 155.6.0.5, 00:20:01, Serial1/0.1
D EX 31.0.0.0 [170/2561024256] via 155.6.0.5, 00:20:01, Serial1/0.1
150.6.0.0/16 is variably subnetted, 6 subnets, 2 masks
D 150.6.8.0/24 [90/20642560] via 155.6.0.5, 00:35:31, Serial1/0.1
D 150.6.10.0/24 [90/20645120] via 155.6.0.5, 00:35:31, Serial1/0.1
30.0.0.0/16 is subnetted, 4 subnets
D EX 30.2.0.0 [170/2561024256] via 155.6.0.5, 00:20:02, Serial1/0.1
D EX 30.3.0.0 [170/2561024256] via 155.6.0.5, 00:20:02, Serial1/0.1
D EX 30.0.0.0 [170/2561024256] via 155.6.0.5, 00:20:02, Serial1/0.1
D EX 30.1.0.0 [170/2561024256] via 155.6.0.5, 00:20:02, Serial1/0.1

Plus the local connected OSPF route:
Rack6R3(config-router)#do sh ip os in br
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa0/0 1 0 155.6.37.3/24 1 BDR 1/1

**NOTE**

This changes when you do redistribute connected you will have to manually add the interfaces or ip prefix to a route-map under the redist connected statement

OSPF metric-type 1 vs metric-type 2

Redistributed as Metric-Type 2 (default redistribution method):

Rack7R4(config-router)#do sh run | s router ospf
router ospf 1
log-adjacency-changes
redistribute rip subnets
network 155.7.45.4 0.0.0.0 area 0
network 155.7.146.4 0.0.0.0 area 0

Rack7R6#sh ip route 204.12.7.0
Routing entry for 204.12.7.0/24
Known via “ospf 1”, distance 110, metric 20, type extern 2, forward metric 1
Last update from 155.7.146.4 on FastEthernet0/0.146, 00:05:09 ago
Routing Descriptor Blocks:
* 155.7.146.4, from 150.7.4.4, 00:05:09 ago, via FastEthernet0/0.146
Route metric is 20, traffic share count is 1

Redistributed as Metric-Type 1:

Rack7R4(config-router)#do sh run | s router ospf
router ospf 1
log-adjacency-changes
redistribute rip metric-type 1 subnets
network 155.7.45.4 0.0.0.0 area 0
network 155.7.146.4 0.0.0.0 area 0

Rack7R6#sh ip route 204.12.7.0
Routing entry for 204.12.7.0/24
Known via “ospf 1”, distance 110, metric 21, type extern 1
Last update from 155.7.146.4 on FastEthernet0/0.146, 00:00:03 ago
Routing Descriptor Blocks:
* 155.7.146.4, from 150.7.4.4, 00:00:03 ago, via FastEthernet0/0.146
Route metric is 21, traffic share count is 1

Output based from INE Volume I topology:

Screenshot 2014-01-05 01.59.06

OSPF sham link configuration – Cisco

SHAM LINK created in VRF in same area as VRF
Loopback inteface for src/dest of SHAM LINK created in VRF
Looback advertised into BGP as VPNv4 route
*optional* ROUTE-MAP to keep Loopback from redistributed into CE routers

PE1

PE1(config-router)#router ospf 1000 vrf C11_12
PE1(config-router)#area 1000 sham-link 10.2.1.1 10.2.1.2 cost 40
!
int loop1
ip vrf forwarding C11_12
ip add 10.2.1.1 255.255.255.255
!
router bgp 65123
address-family ipv4 vrf C11_12
neighbor 129.53.20.20 remote-as 65123
neighbor 129.53.20.20 activate
network 10.2.1.1 mask 255.255.255.255
!
!
route-map SHAM_LINK deny 10
match ip address SHAM_LINK
route-map SHAM_LINK permit 20
!
ip access-list standard SHAM_LINK
permit 10.2.1.1
permit 10.2.1.2
!
router ospf 1000 vrf C11_12
redistribute bgp 65123 subnets route-map SHAM_LINK
network 10.10.111.1 0.0.0.0 area 1000

PE2

PE2(config-router)#router ospf 1000 vrf C11_12
PE2(config-router)#area 1000 sham-link 10.2.1.2 10.2.1.1 cost 40
!
int loop1
ip vrf forwarding C11_12
ip add 10.2.1.2 255.255.255.255
!
router bgp 65123
address-family ipv4 vrf C11_12
neighbor 129.53.10.10 remote-as 65123
neighbor 129.53.10.10 activate
network 10.2.1.2 mask 255.255.255.255
!
!
route-map SHAM_LINK deny 10
match ip address SHAM_LINK
route-map SHAM_LINK permit 20
!
ip access-list standard SHAM_LINK
permit 10.2.1.1
permit 10.2.1.2
!
router ospf 1000 vrf C11_12
redistribute bgp 65123 subnets route-map SHAM_LINK
network 10.10.112.2 0.0.0.0 area 1000

Screenshot 2014-03-20 08.18.07

Cisco MQC HQF strict priority

policy-map FIFO
class MYCLASS_CM
priority 100
class MARK_CM
bandwidth remaining percent 10

Rack1R1(config-pmap-c)#do sh policy-map int
Serial1/1

Service-policy output: FIFO

queue stats for all priority classes:

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 0/0

Class-map: MYCLASS_CM (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: none

    Priority: 100 kbps

, burst bytes 2500, b/w exceed drops: 0

Rack1R1(config-pmap-c)#policy-map FIFO
Rack1R1(config-pmap)# class MARK_CM
Rack1R1(config-pmap-c)#no bandwidth remaining percent 10
Rack1R1(config-pmap-c)#policy-map FIFO
Rack1R1(config-pmap)# class MYCLASS_CM
Rack1R1(config-pmap-c)#priority
Rack1R1(config-pmap-c)# class MARK_CM
Rack1R1(config-pmap-c)#bandwidth 10
bandwidth kbps/percent command cannot co-exist with strict priority or with priority level in the same policy-map

policy-map FIFO
class MYCLASS_CM
priority
class MARK_CM
bandwidth remaining percent 10
class class-default
fair-queue

Rack1R1(config-pmap-c)#do sh policy-map int
Serial1/1

Service-policy output: FIFO

queue stats for all priority classes:

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 0/0

Class-map: MYCLASS_CM (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: none

    Priority: Strict

, burst bytes 1500, b/w exceed drops: 0

Cisco MQC and/or HQF match order top down

Match on destination MAC after permitting BGP to receive the routes from BGP neighbor

108.bgp
(IMAGE from Hacking Cisco blog)

R4#sh run class-map
!
class-map match-all BGP_CM
match protocol bgp
class-map match-all R2_MAC_CM
match destination-address mac C201.1AA8.0000
class-map match-all R1_MAC_CM
match destination-address mac C200.1AA8.0000
!
end

R4#sh run policy-map
!
policy-map MAC_PM
class BGP_CM
class R1_MAC_CM
drop
class R2_MAC_CM
police cir 8000
conform-action transmit
!
end

R4#sh policy-map interface
FastEthernet0/0

Service-policy output: MAC_PM

Class-map: BGP_CM (match-all)
47 packets, 3771 bytes
5 minute offered rate 0 bps
Match: protocol bgp

Class-map: R1_MAC_CM (match-all)
5 packets, 590 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: destination-address mac C200.1AA8.0000
drop

Class-map: R2_MAC_CM (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: destination-address mac C201.1AA8.0000
police:
cir 8000 bps, bc 1500 bytes
conformed 0 packets, 0 bytes; actions:
transmit
exceeded 0 packets, 0 bytes; actions:
drop
conformed 0 bps, exceed 0 bps

Class-map: class-default (match-any)
50 packets, 5044 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

R4#sh ip bgp summ
BGP router identifier 172.16.144.4, local AS number 40
BGP table version is 29, main routing table version 29
20 network entries using 2400 bytes of memory
27 path entries using 1404 bytes of memory
9/5 BGP path/bestpath attribute entries using 1116 bytes of memory
6 BGP AS-PATH entries using 144 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 3 (at peak 3) using 96 bytes of memory
BGP using 5160 total bytes of memory
BGP activity 85/65 prefixes, 112/85 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.1.14.1 4 10 1261 1251 29 0 0 00:06:20 6
10.1.24.2 4 20 1261 1249 29 0 0 00:06:20 7
R4#sh ip route 10.1.14.1
Routing entry for 10.1.14.0/24
Known via “connected”, distance 0, metric 0 (connected, via interface)
Redistributing via bgp 40
Advertised by bgp 40
Routing Descriptor Blocks:
* directly connected, via FastEthernet0/0.14
Route metric is 0, traffic share count is 1

R4#sh ip route 172.16.101.1
Routing entry for 172.16.101.0/24
Known via “bgp 40”, distance 20, metric 0
Tag 10, type external
Last update from 10.1.14.1 00:05:30 ago
Routing Descriptor Blocks:
* 10.1.14.1, from 10.1.14.1, 00:05:30 ago
Route metric is 0, traffic share count is 1
AS Hops 1
Route tag 10

R4#ping 10.1.14.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.14.1, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
R4#ping 172.16.101.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.101.1, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)