NEXUS training

http://dipnut.com/nexus/

Advertisements

Common Ethernet type codes

0x86dd ipv6
0x0800 ipv4
0x8863 PPPoE-Discovery
0x8864 PPPoE “data”
0x0806 ARP

R1#sh run int s0/0
Building configuration…

Current configuration : 138 bytes
!
interface Serial0/0
no ip address
encapsulation frame-relay
ipv6 address 2001::1/64
frame-relay map ipv6 2001::2 102 broadcast
end

R1#debug frame-relay packet
Frame Relay packet debugging is on
R1#ping 2001::2 repeat 1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 2001::2, timeout is 2 seconds:
.
Success rate is 0 percent (0/1)

Apr 4 19:13:33.080: Serial0/0(o): dlci 102(0x1861), pkt type 0x86DD(IPV6), datagramsize 104
R1#

vrf IMPORT-MAP

vrf IMPORT-MAP only filters, still need to use route-target import to bring routes into BGP table

en
conf t
host R1
int f0/0
ip add 1.1.1.1 255.255.255.0
no shut
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 1.1.1.2 remote-as 1
!
address-family vpnv4
neighbor 1.1.1.2 activate
neighbor 1.1.1.2 send-community both
exit-address-family
!
address-family ipv4 vrf R1
redistribute connected
no synchronization
exit-address-family

ip vrf R1
rd 10:10
route-target export 200:200

int loop 20
ip vrf forwarding R1
ip address 30.30.30.1 255.255.255.255

ip vrf R2
rd 20:20
route-target export 100:100

int loop 30
ip vrf forwarding R2
ip add 20.20.20.1 255.255.255.255

int loop40
ip vrf forwarding R2
ip add 40.40.40.1 255.255.255.255

en
conf t
host R2
int f0/0
ip add 1.1.1.2 255.255.255.0
no shut
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
exit-address-family

ip vrf R1
rd 10:10
import map IMPORT_RT_100_100
route-target import 100:100
route-target import 200:200

import map IMPORT_RT_100_100

ip extcommunity-list 1 permit rt 100:100

ip prefix-list IMPORT_RT_100_100 seq 5 permit 20.20.20.1/32

route-map IMPORT_RT_100_100 permit 10
match ip address prefix-list IMPORT_RT_100_100
match extcommunity 1

R2(config-route-map)#do sh bgp vpnv4 unicast rd 10:10
BGP table version is 49, local router ID is 1.1.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 10:10 (default for vrf R1)
*>i20.20.20.1/32 1.1.1.1 0 100 0 ?
*>i30.30.30.1/32 1.1.1.1 0 100 0 ?