Partitions and Calling search Spaces

Partitions and Calling search Spaces

Partitions: Groups of dialable numbers
-Lines
-Route Patterns
-Anything that has a number

Calling Search Spaces (CSS): A list of Reachable Partitions
-Assigned to any ‘dialing’ entity
-Defines calling priviliges

By default all numbers are assigned to the [none] partition
By default all devices are assigned to the [none] CSS

This default allows everyone to call everyone by default

Practical Setup:

Three types of calling restriction should exist in your

organization:
– Lobby/Public phones: internal extensions only
– Typical users: internal and local pstn
– Management: internal, local, and long distance pstn

Step 1: Creat the Partitions
Step 2: Assign numbers to partitions
Step 3: Create CSSs
Step 4: Assign CSSs to devices

EXAMPLE CSS and Partitions:
INT_CSS
-Internal_PT

LOCAL_PSTN_CSS
-Internal_PT
-Local_PSTN_PT

LD_PSTN_CSS
-Internal_PT
-Local_PSTN_PT
-LD_PSTN_PT

Advertisements

Hunt Pilot Groups

CCM_Hunt_Group_Arch

Build from the bottom up:
Line Group
Hunt List
Hunt Pilot

RNA (Ring No Answer) Reversion Timeout – how long to ring before moving to next Line

Note on Urgent Priority check box, for example if you create 911 hunt pilot or route pattern and check this box, it will dial this number as soon as it matches the digits 911

CCM Route Plan Architecture

CCM_Route_Plan_Arch

Route Plan is built from the bottom to the top
1st Device (you can link device direct to Route Pattern but can only be done ONCE hence Route Groups)
2nd Route Group (can have mulitples)
3rd Route List (can have mulitples)
4th Route Pattern

To build route plan:
ADD Gateways (routers, IPs, Ports)
ADD Trunks (IP to other CCMs or Gatekeepers or SIP trunks)

PPP over Frame Relay with router as Frame Switch

PPPoFR_config_with_FR_switch_config.jpeghostname R1
!
!
multilink bundle-name authenticated
!
!
int loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Multilink1
ip unnumbered loopback 0
ppp multilink
ppp multilink interleave
ppp multilink group 1
!
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay traffic-shaping
!
interface Serial0/0.120 point-to-point
snmp trap link-status
frame-relay interface-dlci 120 ppp Virtual-Template1
!
interface Virtual-Template1
no ip address
ppp multilink
ppp multilink group 1

R2:

hostname R2
!
!
frame-relay switching
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay intf-type dce
frame-relay route 120 interface Serial0/1 23
!
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay intf-type dce
frame-relay route 23 interface Serial0/0 120

hostname R3
!
!
multilink bundle-name authenticated

int loopback0
ip address 1.1.1.3 255.255.255.0
!
interface Multilink1
ip unnumbered loopback 0
ppp multilink
ppp multilink interleave
ppp multilink group 1
!
!
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay traffic-shaping
!
interface Serial0/1.23 point-to-point
snmp trap link-status
frame-relay interface-dlci 23 ppp Virtual-Template1
!
interface Virtual-Template1
no ip address
ppp multilink
ppp multilink group 1

Spanning Tree port roles pvst and rapid-pvst ‘show spanning-tree’

Spanning Tree switches

Spanning Tree switches

Working to get all the rapid-pvst port roles to show up in output of ‘show spanning-tree’ command, got that to work but noticed that these same roles show up in the pvst(ieee) output as well…

I believe this is just a cli output issue, as the states still process correctly (lis, lrn, fwd)

The diagram shows the 2 switches with a “loopback” cable (port g0/51 – g0/52) causing the BACKUP port role to show up as I did not have a real hub and needed the switch bpdu to return to itself to cause this BACKUP port role…

CLI OUTPUT from top switch NATIVE_4 and the ROOT switch NATIVE_2:

NATIVE_4#sh spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0021.1bf4.bd00
Cost 4
Port 1 (GigabitEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 4 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0022.0c4f.1c00
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface Role Sts Cost Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Gi0/1 Root FWD 4 128.1 P2p
Gi0/48 Altn BLK 4 128.48 P2p
Gi0/51 Desg FWD 4 128.51 P2p
Gi0/52 Back BLK 4 128.52 P2p

NATIVE_2#sh spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0021.1bf4.bd00
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 4 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0021.1bf4.bd00
Hello Time 2 sec Max Age 20 sec Forward Delay 4 sec
Aging Time 300 sec
Interface Role Sts Cost Prio.Nbr Type
——————- —- — ——— ——– ——————————–
Gi0/1 Desg FWD 4 128.1 P2p
Gi0/48 Desg FWD 4 128.48 P2p

method to “calculate” 6to4 tunnel address

http://www.cisco.com/en/US/docs/ios/ipv6/configuration/guide/ip6-addrg_bsc_con_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1133726

Method to “calculate” 6to4 tunnel address.
Command was introduced: 12.3(4)T
!
interface Loopback0
ip address 157.1.1.1 255.255.255.0
!
R1(config)#ipv6 unicast-routing
R1(config)#ipv6 general-prefix myPref 6to4 loop0
R1(config)#do sh ipv6 general-prefix
IPv6 Prefix myPref, acquired via 6to4
2002:9D01:101::/48
R1(config)#