Cisco IPv6 6to4 tunnel

en
conf t
host R1
int s1/2
ip add 16.16.16.1 255.255.255.0
no shut
int loop0
ip add 129.53.1.1 255.255.255.0
router rip
ver 2
network 0.0.0.0
no auto
!
int loop1
ipv6 address 2002:8135:101:1::1/64
!
interface tunnel 126
tunnel source loop0
tunnel mode ipv6ip 6to4
ipv6 address 2002:8135:101::1/64
!
ipv6 route 2002::/16 tunnel 126

en
conf t
host R2
int s1/2
ip add 26.26.26.2 255.255.255.0
no shut
int loop0
ip add 129.53.2.2 255.255.255.0
router rip
ver 2
network 0.0.0.0
no auto
!
int loop2
ipv6 address 2002:8135:202:2::2/64
!
interface tunnel 126
tunnel source loop0
tunnel mode ipv6ip 6to4
ipv6 address 2002:8135:202::1/64
!
ipv6 route 2002::/16 tunnel 126

en
conf t
host R6
int s2/2
ip add 26.26.26.6 255.255.255.0
no shut
int s2/1
ip add 16.16.16.6 255.255.255.0
no shut
int loop0
ip add 129.53.6.6 255.255.255.0
router rip
ver 2
network 0.0.0.0
no auto
!
int loop6
ipv6 address 2002:8135:606:6::6/64
!
interface tunnel 126
tunnel source loop0
tunnel mode ipv6ip 6to4
ipv6 address 2002:8135:606::1/64
!
ipv6 route 2002::/16 tunnel 126

foreach ipv6 {
2002:8135:101:1::1
2002:8135:202:2::2
2002:8135:606:6::6
} { ping $ipv6 }

R2(tcl)#foreach ipv6 {
+>(tcl)#2002:8135:101:1::1
+>(tcl)#2002:8135:202:2::2
+>(tcl)#2002:8135:606:6::6
+>(tcl)#} { ping $ipv6 }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:8135:101:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:8135:202:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/3/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:8135:606:6::6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms
R2(tcl)#

Screenshot 2014-03-28 06.59.10

Cisco ISATAP example

en
conf t
host R1
int s1/2
ip add 16.16.16.1 255.255.255.0
no shut
int loop0
ip add 129.53.1.1 255.255.255.0
router rip
ver 2
network 0.0.0.0
no auto
int loop1
ipv6 address 2001:db8:1::1/64
!
interface tunnel 126
tunnel source loop0
tunnel mode ipv6ip isatap
ipv6 address 2001:DB8:126::/64 eui-64
!
ipv6 route ::/0 2001:DB8:126::5EFE:8135:606

en
conf t
host R2
int s1/2
ip add 26.26.26.2 255.255.255.0
no shut
int loop0
ip add 129.53.2.2 255.255.255.0
router rip
ver 2
network 0.0.0.0
no auto
int loop2
ipv6 address 2001:db8:2::2/64
!
!
interface tunnel 126
tunnel source loop0
tunnel mode ipv6ip isatap
ipv6 address 2001:DB8:126::/64 eui-64
!
ipv6 route ::/0 2001:DB8:126::5EFE:8135:606

en
conf t
host R6
int s2/2
ip add 26.26.26.6 255.255.255.0
no shut
int s2/1
ip add 16.16.16.6 255.255.255.0
no shut
int loop0
ip add 129.53.6.6 255.255.255.0
router rip
ver 2
network 0.0.0.0
no auto
!
ipv6 unicast-routing
!
interface tunnel 126
tunnel source loop0
tunnel mode ipv6ip isatap
ipv6 address 2001:DB8:126::/64 eui-64
!
ipv6 route 2001:db8:1::/64 2001:DB8:126::5EFE:8135:101
ipv6 route 2001:db8:2::/64 2001:DB8:126::5EFE:8135:202

Screenshot 2014-03-28 06.59.10

MPLS LDP bindings detail – MPLS IP bindings detail

!
R4, R5, R6:
access-list 10 permit 150.1.0.0 0.0.255.255
access-list 10 permit 150.9.0.0 0.0.255.255
!
no mpls ldp advertise-labels
mpls ldp advertise-labels for 10

MPLS LDP bindings detail:

Rack9R4#sh mpls ldp bindings
lib entry: 54.9.1.0/24, rev 21
local binding: label: 16
lib entry: 150.9.4.4/32, rev 31
local binding: label: imp-null
remote binding: lsr: 150.9.5.5:0, label: 17
remote binding: lsr: 150.9.6.6:0, label: 16
lib entry: 150.9.5.5/32, rev 32
local binding: label: 17
remote binding: lsr: 150.9.5.5:0, label: imp-null
remote binding: lsr: 150.9.6.6:0, label: 17
lib entry: 150.9.6.6/32, rev 33
local binding: label: 18
remote binding: lsr: 150.9.5.5:0, label: 18
remote binding: lsr: 150.9.6.6:0, label: imp-null
lib entry: 155.9.0.0/24, rev 25
local binding: label: imp-null
lib entry: 155.9.5.0/24, rev 26
local binding: label: 19
lib entry: 155.9.45.0/24, rev 27
local binding: label: imp-null
lib entry: 155.9.58.0/24, rev 28
local binding: label: 20
lib entry: 155.9.146.0/24, rev 29
local binding: label: imp-null
lib entry: 204.12.9.0/24, rev 30
local binding: label: imp-null
Rack9R4#

Rack9R4#sh mpls ldp bindings detail
Advertisement spec:
Prefix acl = 10

lib entry: 54.9.1.0/24, rev 21, chkpt: none
local binding: label: 16 (owner LDP)
route information: state: none, table: default,
next-hop: 155.9.146.6, remote label:
lib entry: 150.9.4.4/32, rev 31, chkpt: none
local binding: label: imp-null (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
remote binding: lsr: 150.9.5.5:0, label: 17
remote binding: lsr: 150.9.6.6:0, label: 16
route information: state: none, table: default,
next-hop: 0.0.0.0, remote label:
Advert acl(s): Prefix acl 10
lib entry: 150.9.5.5/32, rev 32, chkpt: none
local binding: label: 17 (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
remote binding: lsr: 150.9.5.5:0, label: imp-null
remote binding: lsr: 150.9.6.6:0, label: 17
route information: state: none, table: default,
next-hop: 155.9.0.5, remote label: imp-null
route information: state: none, table: default,
next-hop: 155.9.45.5, remote label: imp-null
Advert acl(s): Prefix acl 10
lib entry: 150.9.6.6/32, rev 33, chkpt: none
local binding: label: 18 (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
remote binding: lsr: 150.9.5.5:0, label: 18
remote binding: lsr: 150.9.6.6:0, label: imp-null
route information: state: none, table: default,
next-hop: 155.9.146.6, remote label: imp-null
Advert acl(s): Prefix acl 10
lib entry: 155.9.0.0/24, rev 25, chkpt: none
local binding: label: imp-null (owner LDP)
route information: state: none, table: default,
next-hop: 0.0.0.0, remote label:
lib entry: 155.9.5.0/24, rev 26, chkpt: none
local binding: label: 19 (owner LDP)
route information: state: none, table: default,
next-hop: 155.9.0.5, remote label:
route information: state: none, table: default,
next-hop: 155.9.45.5, remote label:
lib entry: 155.9.45.0/24, rev 27, chkpt: none
local binding: label: imp-null (owner LDP)
route information: state: none, table: default,
next-hop: 0.0.0.0, remote label:
lib entry: 155.9.58.0/24, rev 28, chkpt: none
local binding: label: 20 (owner LDP)
route information: state: none, table: default,
next-hop: 155.9.0.5, remote label:
route information: state: none, table: default,
next-hop: 155.9.45.5, remote label:
lib entry: 155.9.146.0/24, rev 29, chkpt: none
local binding: label: imp-null (owner LDP)
route information: state: none, table: default,
next-hop: 0.0.0.0, remote label:
lib entry: 204.12.9.0/24, rev 30, chkpt: none
local binding: label: imp-null (owner LDP)
route information: state: none, table: default,
next-hop: 0.0.0.0, remote label:
Rack9R4#

MPLS IP bindings detail

Rack9R4#sh mpls ip binding
54.9.1.0/24
in label: 16
150.9.4.4/32
in label: imp-null
out label: 17 lsr: 150.9.5.5:0
out label: 16 lsr: 150.9.6.6:0
150.9.5.5/32
in label: 17
out label: imp-null lsr: 150.9.5.5:0 inuse
out label: 17 lsr: 150.9.6.6:0
150.9.6.6/32
in label: 18
out label: 18 lsr: 150.9.5.5:0
out label: imp-null lsr: 150.9.6.6:0 inuse
155.9.0.0/24
in label: imp-null
155.9.5.0/24
in label: 19
155.9.45.0/24
in label: imp-null
155.9.58.0/24
in label: 20
155.9.146.0/24
in label: imp-null
204.12.9.0/24
in label: imp-null
Rack9R4#

Rack9R4#sh mpls ip binding detail
Advertisement spec:
Prefix acl = 10

54.9.1.0/24, rev 21, chkpt: none
in label: 16 (owner LDP)
150.9.4.4/32, rev 31, chkpt: none
in label: imp-null (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
out label: 17 lsr: 150.9.5.5:0
out label: 16 lsr: 150.9.6.6:0
Advert acl(s): Prefix acl 10
150.9.5.5/32, rev 32, chkpt: none
in label: 17 (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
out label: imp-null lsr: 150.9.5.5:0 inuse
out label: 17 lsr: 150.9.6.6:0
Advert acl(s): Prefix acl 10
150.9.6.6/32, rev 33, chkpt: none
in label: 18 (owner LDP)
Advertised to:
150.9.5.5:0 150.9.6.6:0
out label: 18 lsr: 150.9.5.5:0
out label: imp-null lsr: 150.9.6.6:0 inuse
Advert acl(s): Prefix acl 10
155.9.0.0/24, rev 25, chkpt: none
in label: imp-null (owner LDP)
155.9.5.0/24, rev 26, chkpt: none
in label: 19 (owner LDP)
155.9.45.0/24, rev 27, chkpt: none
in label: imp-null (owner LDP)
155.9.58.0/24, rev 28, chkpt: none
in label: 20 (owner LDP)
155.9.146.0/24, rev 29, chkpt: none
in label: imp-null (owner LDP)
204.12.9.0/24, rev 30, chkpt: none
in label: imp-null (owner LDP)
Rack9R4#

Cisco redistribution – show commands

Rack6R4(config-router)#do sh run | s router
router eigrp 1
redistribute rip metric 1 1 1 1 1
network 155.6.0.0 0.0.0.255
no auto-summary
router ospf 1
log-adjacency-changes
network 155.6.45.4 0.0.0.0 area 0
network 155.6.146.4 0.0.0.0 area 0
router rip
version 2
redistribute eigrp 1 metric 10
network 204.12.6.0
distance 109

To see the EIGRP routes redistributed into RIP:

Rack6R4(config-router)#do sh ip rip data | i redistributed
150.6.8.0/24 redistributed
150.6.10.0/24 redistributed
155.6.0.0/24 redistributed
155.6.5.0/24 redistributed
155.6.8.0/24 redistributed
155.6.10.0/24 redistributed
155.6.58.0/24 redistributed
155.6.108.0/24 redistributed

Rack6R4(config-router)#do sh ip route ei
155.6.0.0/24 is subnetted, 13 subnets
D 155.6.8.0 [90/2172672] via 155.6.0.5, 00:24:08, Serial0/0/0.1
D 155.6.10.0 [90/2175232] via 155.6.0.5, 00:24:08, Serial0/0/0.1
D 155.6.5.0 [90/2172416] via 155.6.0.5, 00:24:08, Serial0/0/0.1
D 155.6.58.0 [90/2172416] via 155.6.0.5, 00:24:08, Serial0/0/0.1
D 155.6.108.0 [90/2174976] via 155.6.0.5, 00:24:08, Serial0/0/0.1
150.6.0.0/16 is variably subnetted, 6 subnets, 2 masks
D 150.6.8.0/24 [90/2300416] via 155.6.0.5, 00:24:08, Serial0/0/0.1
D 150.6.10.0/24 [90/2302976] via 155.6.0.5, 00:24:08, Serial0/0/0.1

To see the RIP routes redistributed into EIGRP:
Rack6R4(config-router)#do sh ip route rip
31.0.0.0/16 is subnetted, 4 subnets
R 31.3.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 31.2.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 31.1.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 31.0.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
30.0.0.0/16 is subnetted, 4 subnets
R 30.2.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 30.3.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 30.0.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
R 30.1.0.0 [109/1] via 204.12.6.254, 00:00:07, FastEthernet0/0
Rack6R4(config-router)#do sh ip eigrp topo | i Redist
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
via Redistributed (2560000256/0)
8 rip routes Plus the local connected:
P 204.12.6.0/24, 1 successors, FD is 2560000256
via Redistributed (2560000256/0)

To see the any route redistributed into OSPF:

router ospf 1
log-adjacency-changes
network 155.6.37.3 0.0.0.0 area 0
redistribute eigrp 1 subnets

Rack6R3(config-router)#do sh ip ospf data | b Type-5
Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
30.0.0.0 150.6.3.3 1182 0×80000001 0x00BD22 0
30.1.0.0 150.6.3.3 1182 0×80000001 0x00B12D 0
30.2.0.0 150.6.3.3 1182 0×80000001 0x00A538 0
30.3.0.0 150.6.3.3 1182 0×80000001 0×009943 0
31.0.0.0 150.6.3.3 1182 0×80000001 0x00B02E 0
31.1.0.0 150.6.3.3 1182 0×80000001 0x00A439 0
31.2.0.0 150.6.3.3 1182 0×80000001 0×009844 0
31.3.0.0 150.6.3.3 1182 0×80000001 0x008C4F 0
150.6.8.0 150.6.3.3 86 0×80000002 0x00FC5B 0
150.6.10.0 150.6.3.3 86 0×80000002 0x00E66F 0
155.6.0.0 150.6.3.3 86 0×80000002 0×001447 0
155.6.5.0 150.6.3.3 86 0×80000002 0x00DC79 0
155.6.8.0 150.6.3.3 86 0×80000002 0x00BB97 0
155.6.10.0 150.6.3.3 86 0×80000002 0x00A5AB 0
155.6.58.0 150.6.3.3 87 0×80000002 0x00938D 0
155.6.108.0 150.6.3.3 87 0×80000002 0x006B83 0
204.12.6.0 150.6.3.3 87 0×80000002 0x000A14 0

Rack6R3(config-router)#do sh ip route eig
155.6.0.0/24 is subnetted, 15 subnets
D 155.6.8.0 [90/20514816] via 155.6.0.5, 00:35:31, Serial1/0.1
D 155.6.10.0 [90/20517376] via 155.6.0.5, 00:35:31, Serial1/0.1
D 155.6.5.0 [90/20514560] via 155.6.0.5, 00:35:31, Serial1/0.1
D 155.6.58.0 [90/20514560] via 155.6.0.5, 00:35:31, Serial1/0.1
D 155.6.108.0 [90/20517120] via 155.6.0.5, 00:35:31, Serial1/0.1
D EX 204.12.6.0/24 [170/2561024256] via 155.6.0.5, 00:35:31, Serial1/0.1
31.0.0.0/16 is subnetted, 4 subnets
D EX 31.3.0.0 [170/2561024256] via 155.6.0.5, 00:20:01, Serial1/0.1
D EX 31.2.0.0 [170/2561024256] via 155.6.0.5, 00:20:01, Serial1/0.1
D EX 31.1.0.0 [170/2561024256] via 155.6.0.5, 00:20:01, Serial1/0.1
D EX 31.0.0.0 [170/2561024256] via 155.6.0.5, 00:20:01, Serial1/0.1
150.6.0.0/16 is variably subnetted, 6 subnets, 2 masks
D 150.6.8.0/24 [90/20642560] via 155.6.0.5, 00:35:31, Serial1/0.1
D 150.6.10.0/24 [90/20645120] via 155.6.0.5, 00:35:31, Serial1/0.1
30.0.0.0/16 is subnetted, 4 subnets
D EX 30.2.0.0 [170/2561024256] via 155.6.0.5, 00:20:02, Serial1/0.1
D EX 30.3.0.0 [170/2561024256] via 155.6.0.5, 00:20:02, Serial1/0.1
D EX 30.0.0.0 [170/2561024256] via 155.6.0.5, 00:20:02, Serial1/0.1
D EX 30.1.0.0 [170/2561024256] via 155.6.0.5, 00:20:02, Serial1/0.1

Plus the local connected OSPF route:
Rack6R3(config-router)#do sh ip os in br
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa0/0 1 0 155.6.37.3/24 1 BDR 1/1

**NOTE**

This changes when you do redistribute connected you will have to manually add the interfaces or ip prefix to a route-map under the redist connected statement

OSPF metric-type 1 vs metric-type 2

Redistributed as Metric-Type 2 (default redistribution method):

Rack7R4(config-router)#do sh run | s router ospf
router ospf 1
log-adjacency-changes
redistribute rip subnets
network 155.7.45.4 0.0.0.0 area 0
network 155.7.146.4 0.0.0.0 area 0

Rack7R6#sh ip route 204.12.7.0
Routing entry for 204.12.7.0/24
Known via “ospf 1″, distance 110, metric 20, type extern 2, forward metric 1
Last update from 155.7.146.4 on FastEthernet0/0.146, 00:05:09 ago
Routing Descriptor Blocks:
* 155.7.146.4, from 150.7.4.4, 00:05:09 ago, via FastEthernet0/0.146
Route metric is 20, traffic share count is 1

Redistributed as Metric-Type 1:

Rack7R4(config-router)#do sh run | s router ospf
router ospf 1
log-adjacency-changes
redistribute rip metric-type 1 subnets
network 155.7.45.4 0.0.0.0 area 0
network 155.7.146.4 0.0.0.0 area 0

Rack7R6#sh ip route 204.12.7.0
Routing entry for 204.12.7.0/24
Known via “ospf 1″, distance 110, metric 21, type extern 1
Last update from 155.7.146.4 on FastEthernet0/0.146, 00:00:03 ago
Routing Descriptor Blocks:
* 155.7.146.4, from 150.7.4.4, 00:00:03 ago, via FastEthernet0/0.146
Route metric is 21, traffic share count is 1

Output based from INE Volume I topology:

Screenshot 2014-01-05 01.59.06

OSPF sham link configuration – Cisco

SHAM LINK created in VRF in same area as VRF
Loopback inteface for src/dest of SHAM LINK created in VRF
Looback advertised into BGP as VPNv4 route
*optional* ROUTE-MAP to keep Loopback from redistributed into CE routers

PE1

PE1(config-router)#router ospf 1000 vrf C11_12
PE1(config-router)#area 1000 sham-link 10.2.1.1 10.2.1.2 cost 40
!
int loop1
ip vrf forwarding C11_12
ip add 10.2.1.1 255.255.255.255
!
router bgp 65123
address-family ipv4 vrf C11_12
neighbor 129.53.20.20 remote-as 65123
neighbor 129.53.20.20 activate
network 10.2.1.1 mask 255.255.255.255
!
!
route-map SHAM_LINK deny 10
match ip address SHAM_LINK
route-map SHAM_LINK permit 20
!
ip access-list standard SHAM_LINK
permit 10.2.1.1
permit 10.2.1.2
!
router ospf 1000 vrf C11_12
redistribute bgp 65123 subnets route-map SHAM_LINK
network 10.10.111.1 0.0.0.0 area 1000

PE2

PE2(config-router)#router ospf 1000 vrf C11_12
PE2(config-router)#area 1000 sham-link 10.2.1.2 10.2.1.1 cost 40
!
int loop1
ip vrf forwarding C11_12
ip add 10.2.1.2 255.255.255.255
!
router bgp 65123
address-family ipv4 vrf C11_12
neighbor 129.53.10.10 remote-as 65123
neighbor 129.53.10.10 activate
network 10.2.1.2 mask 255.255.255.255
!
!
route-map SHAM_LINK deny 10
match ip address SHAM_LINK
route-map SHAM_LINK permit 20
!
ip access-list standard SHAM_LINK
permit 10.2.1.1
permit 10.2.1.2
!
router ospf 1000 vrf C11_12
redistribute bgp 65123 subnets route-map SHAM_LINK
network 10.10.112.2 0.0.0.0 area 1000

Screenshot 2014-03-20 08.18.07